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Main window description

The main window of the Work Scheduler Pro is divided into a few parts:

At the top of window there is a toolbar.

In the toolbar there are some buttons, which consecutively cause:

preparing the program for creating a new schedule,
opening a file with an existing schedule (the arrow allows you to quickly open one of the four schedules which
have been recently opened)
saving the created schedule to a file,
opening a window print templates e.g. applications, forms, schedules, etc. (arrow allows you to quickly access to
the one of the four templates, which have been recently the most used);
appearing of the window, where you can select the month for which the schedule will be arranged,
appearing the window, where you can choose a schedule from which the overtime will be imported,
adding a new group of employees,
appearing a window, where you can change the data of the currently selected group of employees,
removing the currently selected group of employees,
adding a new employee to the currently selected group of employees,
appearing a window, where you can change the data of the currently selected employee,
removing the currently selected employee,
arranging schedules automatically for employees selected by the user
appearing warnings for the schedule, which is currently arranged,
opening the window of a configuration of the program
opening the window with information about the version of the scheduler and the user registration data.

Furthermore, there is a list at the end of the bar, which contains a comparison of the number of working days and on-
call duties during the examined month.

In the central part of the main window there is the section - Employee,

which contains:

frame: Employee's normative :
Standard worktime (normative)  - time which the selected employee should work in a month. It is
counted as [(Monthly normative of a group or employee which is given directly by the user (menu:
Workers > Edit > Worktime> Monthly normative) - overtime from the previous month) x "PartTime
value"/100]. In addition, next to the normative, there is a overtime from the previous month displayed.
Unused  - time, which should be assigned to the employee as shifts or as holidays. It is counted as
[Normative of an employee - a sum of allocated shifts and holiday].
Used  - a sum of time of allocated shifts and holiday.
Overtime  - a sum of overtime which is already allocated.

frame: Shifts
Daily  the number of "usual" hours worked by the selected employee, which have a result from the already-
assigned shifts during chosen month.
Night shifts  the number of "night" hours worked by the selected employee, which have a result from the
already-assigned shifts during chosen month.
Holiday  the number of "holiday" hours worked by the selected employee, which have a result from the
already-assigned shifts during chosen month.
Total  Total number of hours worked during selected month by selected employee. It is calculated as the
sum of hours mentioned above.

frame: Holiday
Other holiday  the amount of left hours of holiday which can be used in the current year. This number is
reduced by the time of holiday, when this holiday is assigned to the employee.
Other holiday reh.  the amount of hours of rehabilitation, which are left and can be used in the current



year. This number is reduced by the time of holiday, when this holiday is assigned to the employee
Other childcare  the amount of childcare days which are left and can be used in the current year. This
number is reduced by one day, when the childcare is assigned.
Total  total number of hours, when the employee was absent at work during the selected month. It is
counted as the sum of holiday hours of various types (e.g. holidays, trainings, sick notes, etc.)

frame: Period
Normative  time which the selected employee should work in a period.
Duties  total duration of duties worked in selected period.
Daysoff  total duration of dayoffs used in selected period.
Remain  hours remain to work or extra hours

At the botton of the window there is a Calendar .

Each square with a number corresponds to one day in the selected month. Holidays are automatically determined by the
Scheduler. You can also modify "manually" selecting the holiday by pressing the right mouse button on the selected day
and choosing an option Holiday . In each day, there are as many squares as selected changes for the chosen group of
emplyees. The number of the following day is only on the square which symbolizes the first shift.

The inscriptions on the squares symbolize duties which means, depending on the color and style of the font:

black: shift;
white: shift or holiday allocated to an employee, who has already been removed from the list or moved to another
group of employees;
bold type: shift for which the additional overtime is specified;
italic type: shift marked as "on request";
red: one day of holiday (symbol "x") or first day of holiday if it is longer than one day(symbol "»")

In addition, the squares indicating all shifts and holidays, which are allocated for the currently selected employee, have a
black enframing.

At the top of the calendar, there are elements which allow you to limit the amount of data which is displayed as
following:

Choice of shifts and/or holiday for only  selected employee,
Choice only  shifts or  holidays,

In addition, you can specify if there should be a "short" name of employee displayed or the shift's symbol.

At the bottom of the calendar is a preview of the note entered on the day marked in the calendar (as long as it was
previously entered). The day number for which the note was entered is indicated in green colour.

In the right part of the main window you can turn on the Panel with lists:



Groups of employees e.g.: nurses, hospital porters, employees from
one department (the monthly normative of a group is presented next to
the name).

By left-clicking on an item in the list of group and by dragging it, you can
change their sequence on the list.

Employees (next to the name and surname there are displayed:
"Holidays" hours/number of shifts/number of nights)

Employees can be "dragged" to the calendar directly from the list,
which will add them a shift.

You can activate the list panel by selecting in the menu Tools  position
Panel  (or F4 key). In the panel there is a list of all employees of the
active Group, or regardless of their affiliation (depending on the status
of the option Show option below the list). There are also workers who
have been previously removed. They are marked by a crossed surname
out. By pressing the space key on the removed employee, you can
restore this person.

by left-clicking on an item in the list of the workers and by dragging it,
you can change their sequence on the list.

The colors of the underlining of the each employee mean: red - not
enough shifts, blue - too many assigned shifts and green - assigned
shifts and holidays coinciding with the monthly normative of the
employee.



Adding and modifying groups of workers

The term Group of employees  can be used to define
names of many employees who do the same or similar tasks
like e.g. Nurses

In order to split shifts and holiday, at first you must add
group of employees  and then employees (who will have
shitfs and holiday assigned) who were members of
previously added group of employees.

You can add a group, where employees will be added later, by click Add group  button on the toolbar (menu: or
by menu: Group > Add). In this window, on the Data  tab you have to specify the name of a group. It is optional and
can be later modified (e.g. "Nurses", when the schedule is set for nurses).

On the next bookmark - Shifts  you can specify:

amount of shifts,
start time of shift,
duration of shift,
symbol of shift (it can be used in templates),
color (it can be used in the main window of the Work Scheduler Pro in the Calendar  section),
name of shift,
optimal and recommended amount of employees (staff) on a shift during weekday or holiday (which is used
during automatic assignment of shifts).

Pressing
the button

causes

automatically calculate start time of the following shifts, based on start time and duration of previuos shift.

The Normative  tab contains options which have an impact on calculation of the monthly standard work time. Data from
this bookmark is saved for each month independently. You can specify there:

custom monthly standard work time, after selecting an option
Own normative  (if you do not select this option, the
automatically calculated monthly standard work time is
displayed).
Duration of shift "8",
Warning:  based on this duration, the monthly standard work
time is calculated as a multiplication duration of shift "8" and the
amount of working days in the selected month.
the way of considering Saturdays: as a holiday or as a weekday
decreasing monthly standard work time (or not) when the
holiday take place on Saturday
the way of counting night shifts which take place on holidays
screening the calendar without holidays

Pressing the button Save value as default  accepts the current
settings as default on the Normative  tab for months in which they
have not been determined yet.

After selecting an option Reset default settings
(on Automat  tab) you can get the most optimal
composition of automatically split of shifts
(according to the scheme specified in the
window of Edit data of employee). To reset



settings before every automatically split of shifts,
yoou have to mark an option Always reset
before automat start . The program can split
shifts according to two algorithms. It should be
certify experimentally, which one is more
appropriate for the group. On the Automat  tab

the user can also decide if the overtime should be split by checking an option Distribute normative's residues .

To change data of group of employees click Modify data of the group  button (menu: or by menu: Group >
Edit).

To delete a group of employees, click Delete group  button (menu: or by menu: Group > Delete). Then the group
is removed with employees who are assigned to it. This removal irreversible.



Adding and modifying employee

Added employee can simultaneously belong to many groups of
employees. To add a new employee you have to click Add

employee  button on the toolbar. Next specify the following
data:

On Main  tab:

surname,
name,
nick name (it will be located in the symbol of shift or holiday
of the employee in the calendar),
name of the profession occupied by the employee. It can be selected from the existing list or you can enter your
own, (list of available names can be modified in the window Configuration )
color (selected color will be assigned to the symbol of shift or holiday of the employee in the calendar).

On Group  tab:

a group or groups of employees in which the employee will have the shifts allocated.

On Address  tab and Other  tab (these data can be used in the print templates):

address,
post office,
ZIP code,
phone number,
e-mail,
Personal ID Number,
education, (the list of available educations can be modified in the window Configuration )
courses,
and any 3 additional information about the employee.

On Dayoff  tab:

the amount of hours of holiday from the previous calendar year, which remained to be used in the current year,
the amount of hours of holiday, which remained to be used in the current year. This number will be automatically
reduced after that the holiday has been assigned to the employee,
the number of hours of rehabilitation leave which remained to be used in the current year. This number will be
automatically reduced after that the rehabilitation leave has been assigned to the emplyee.
the number of days of childcare which remained to be use in the current year. This amount will be automatically
reduced after the childcare has been assigned to the worker.

On Worktime  tab:

day job articulated in percentage (e.g. 100% full-time job,
50% part-time job),
individual monthly normative, if it does not squared with the
standard of work which is scheduled by the program and it
can not be expressed as a percentage of the day job,
The number of overtime from the previous month, with the
division into relocated autamatically and entered
independently. If the employee did not earn a standard
worktime in the previous month, then the entered value must
be preceded by a minus sign "-". This number reduces (or
increases with the "-" minus sign ) the monthly standard of work time of an employee. To automatically move
overtime from another month for all employees, you have to specify the file from which you want to move the
overtime (menu: Shifts > Overtime > Load overtime from...),

On Automat  tab you can indicate if the program should automatically assign shifts to the employee and specify the
parameters of their section (details »).

To change the data of employee, select Modify Employee Data  button on the toolbar.



To remove an employee, select Delete employee  button. In order to keep the ability of viewing the shifts and
holiday posted in previous months, removing an employee does not  remove them, but only hide. You can restore the
employee to the list in the Panel in the main window of the Work Scheduler Pro.

Current schedule's parameters

In window Parameters (menu: Project > Parameters) select a month and a
year for which the schedule is arranged. The current month is default for
new created schedulers.

Warning: During changing the month (especially for those who have fewer
days), some duties can be lost in the arranged scheduler.

The Status  option is dedicated to set status of the work schedule. It allows
for generate to computer-server only printouts with "approved" status (when
server is used for storing printouts files). Status may be used by related
varialble, directly in printouts templates.



Adding, modifying and deleting duties

To add a new duty there must  be entered at least one group of employees ,
and at least one employee there. You can add a duty to the employee who is
currently selected on the list Employees  on different ways, for example:

left-click and drag (hold the mouse button) button Duty  above the
desirable shift in the calendar and release the mouse button,
left-click and drag (hold the mouse button) item/name from the list of
employess above the selected change in the calendar and release the
mouse button,
press the key [Insert]  on the keyboard. Then the duty will be inserted
into currently selected Employee on the currently selected shift on the
Calendar ,
right-click on the Calendar  on the selected shift and choose the option
Add duty . Then, the duty will be inserted into the currently selected
Employee on the currently selected shift on the Calendar ,
left-click and press the key Control  [Ctrl] and drag (hold the mouse
button) the already existing duty and drag it to the selected shift on
another day,
click in the Calendar  on the shift, in which you would like to add a duty.
Afterwards, press and hold the [Shift] key on the keyboard and press
the button(s) which is respondent to the Short name  of an employee. If
the short name contains numbers, they cannot be entered from the
numerical keyboard.

After a realization one of the mentioned actions, a window will display, in which you should choose the duration of the
duty between:

8 - the duty will be set with the time determined in the window Groups > Edit group > Normative > Duty "8"
duration  (by default 7:35h),
If the added duty is first in the month of selected employee, the program will ask about settling the same duties
to the remaining days of the month. After confirms by user, it will automatically add duties "8" to all working days
of the selected month.
Whole shift  - there will be inserted a duty which last the whole work shift,
Worker normative residue  - there will be inserted a duty which last time depending on already inserted duties,
dayoffs and overtimes (also from previous month - if imported),
Group normative residue  - there will be inserted a duty which is equal to group normative residue,
Other  - there will be inserted a duty which has the time entered by the user.

To accelerate the insertion of the duty which lasts a whole shift, you have to press the key Control  ([Ctrl] while dropping
the "duty" above the calendar (the key [Ctrl] is located in the lower left corner of the keyboard).

The start time and duration of already added duty can be changed by right-clicking on it and selecting the option Modify
... . Analogously, you can add overtime to the duty. If you need to remove any duty, drag it to the Trash

 or right-click on it and choose option Delete . To fast remove all duties or duties
of selected employee, choose the option Duties  from the menu and then option Delete duties .

You can move duties (by dragging them) between days (or between shifts), in which a selected employee does not
have any duty yet.

You can add a short comment to every duty in the text field Warnings . This comment can be exposed on the printouts.

Selecting the option On demand  marks the duty as added "on demand" of employee. Such marked duty becomes
immovable and it may be removed only after a confirmation. In the main window, in the calendar, descriptions on the
square symbolize this kind of duty and they are written in italics.



Adding and deleting Dayoffs

To add a new holiday, there must  be entered at least one Group of employees , and there at least one employee. To
add a holiday letf-click, drag (hold the mouse button pressed) the button Holiday  above a day in the calendar and
release the mouse button. This added holiday is assigned for a chosen employee located in the Workers  list. Specify
the duration of the holidays and select their type in the displayed window:

Without duty  - the shift while employee would not like to have
any duty assigned . This kind of holiday is not included in any
printout and in any statistics. The symbol is displayed only for the
employee who is currently selected on the Employees  list.
Holiday leave  - adding this kind of holiday will reduce the amount
of hours of holiday leave for use during the current year.
Maternity leave
Parental leave
Sabbatical
Sick leave
Child care  - adding this kind of holiday will reduce the amount of
days of babysitting during the current year.
Play truant  - inexcused absence from work
Other
For work on Sunday
For work on Saturday
LWOP (unpaid leave)
Care for family member
Exemption of the child
Rehabilitation leave
Leave at request
For work on holiday
Special leave
Parental leave
Paternity leave

If there is no added duty during holidays, the time of
holidays will be calculated as the amount of working days during holidays and multiply by the
lenght of the duty "8" (by default 7:35). If during of  introduced holiday, some duties are
added, the time of holiday will be counted as the sum of all times of those duties. Such
inserted duties are used only to define the duration of holiday leave.

The symbols of individual kinds of holidays
and their names (for use in the printouts)
may be specified in the window Settings
on tab Holiday . On this tab you can also
define if a particular kind of holiday should
has an influence on standard working
hours during a month.

A duration of already added holiday cannot
be changed. However, you can delete
(drag it to the Trash

)
the existing holiday and replace it with a new one.



Automatic duties

Work Scheduler Pro provides automatic split of the duties of employees. In order to settle working hours, choose option
Add duties automatically  or press buttons on your keyboard [Ctrl]+[R] at the same time or choose option (menu:
Duties > Add duties automatically).

In order to assign the work shifts for each employee, you have to set up the way of split of work shifts on the tab
Automat (menu: Workers > Edit > Automat).

WARNING:  The program is not able to completely replace a person who arranges a schedule. After each automatic
arrangement of duties, we advice you to check if the schedule is correct.

In the window Edit data of employee (menu:
(menu: Workers > Edit)), on bookmark Automat
you can determine the program in terms of split
duties automatically and specify parameters of
their distribution. When you are adding a new
employee, the option Without  is marked by
default, which means that in this case the duties
have to be assign manually.

Selecting an option Duties "8" on the shift no:  will
assign duties "8" automatically to the specific
employee on a shift designated on a scheme.
Selecting an option Week causes that every
number of shift on a scheme is not repeated every
day but every week (like on undermentioned
example number 3).
Duties "8" by default aren't assigned on holiday. To
change it you should move Normal - Holidays
scrollbar in maximum right position.

Option "System" according to the scheme  means that the person will have duties assigned like on the scheme e.g.
"1200". It means that on the first day, duty will be on a 1st shift (1200), on second day it will be on 2nd shift (1200) but
on third and fourth day (1200) the person will not have any duty assigned. On the fifth day, series starts again and etc.
until the end of the month. The value given in the area starting from  helps to determine what number (number of shift)
given on a scheme will be used on the first day of the month. Suitable configuration of this value among all employees in
the group helps to avoid such situation as: on the first day of the month all employes will be assigned to the first shift
and no employee will be assigned on the second shift.

If it does not matter, who of the employees is on a specific shift during concrete day, the initial value can be quickly
selected for all employess simultaneously just by choosing an option Reset initial settings  in the window Edit data of
employees, on Automat  tab. Also in the same window, on Shifts  tab you can specify the most appropriate number of
employees for each shift.

Scrollbars settings: Days - Nights  and Normal - Holidays  allow you to suit the preferences of employee. Moving a
scrollbar in the direction of the word Holidays  means that an employee prefers to work on holidays than during usual
days. The maximum displacement of the scrollbar in any direction does not mean the assignment of e.g. only holidays.

Automatic assignment was mainly tested on a double day shift. There is no guarantee of its usefulness in other
systems.

Examples:

Duty "8" on a first shift everyday.

Settings:

Result:

1. 



Duty "8" everyday, alternately on frist and second shift.

Settings:

Result:

2. 

Duty "8" every week, nalternately on frist and second shift.

Settings:

Result:

3. 



Full-shifts duties according to the sheme. Due to the lack of continuity at the beginning of the month, some of the
assigned duties have been automatically removed with the aim of approaching to the standard worktime..

Settings:

Result:

4. 



Warnings

There is a possibility to check the composed
graphic for some irregularities, by selecting
in (menu: Tools> Settings > Warnings). You
can choose what kind of irregularities you
want to check.

There are warnings of:

shift's staff quantity different from
setting (menu: Groups > Edit > Shifts
> Staff),
night duties of the same employee on
two consecutive days (it does not
concern cases at the turn of two
months),
too short break between duties of the
same employee (including overtime
assigned to the duty and it does not
concern cases at the turn of two
months),
too long duty (includes overtime
assigned to the duty),
too short duty (includes overtime assigned to the duty),
exceeded standard worktime,
unearned standard worktime,
a break between duties within the arranged week is shorter than a value set by the user. The break is checked in
the following weeks of month i.e. 1-7, 8-14, etc. (it includes overtime which is assigned to the duty and it does
not involve cases at the turn of two months)
count of following, working Sundays

A warning report is displayed in the Notepad, which simplifies alternatively saving it to a text file or printout

obtaining a schedule without warnings does not guarantee its agreement with rules in force.



Daily notes, time line

On each day of chosen month you can
add a text note of any content. In order
to do this, right-click on the chosen day
in Calendar, select option Day
properties  and in the opened Day
properties  window enter or modify the
existing text note.
If the user has marked the holidays as
an usual day, you can restore settings,
which are suggested by the program,
by choosing the option Default holiday
settings.

There is also a possibility to present
graphically the assigned duties of
chosen day. It is therefore advisable to
right-click on the selected day in the
Calendar, select optionDay properties
and in the opened window go to the bookmark Duties . Each duty on the chart is represented by a rectangle of the
length corresponding to the duration of the duty. The part of the rectangle surrounded by dashed line means extra hours.
The colour of the rectangle is the same as colour assigned to the person who is on duty.



Making own print templates

It is worth to create your own templates when you use series of applications at your work, which contain e.g. data of
employees. After creating the template which is filled out and contains data of the employee, you can print it out just by
clicking one mouse button...

The structure of generated documents is get from the templates which are placed in the subdirectory "templates". You
can edit the template by pressing the button Template Edit  which is located in the window Templates . The files with a
template have a WZR extension and can also be modified in any text editor (e.g. Notepad).
WARNING!  Modifying the template has an influence on the appearance of documents (based on the template edit),
which will be created in the future.

There are some templates attached to application (including example of an apllication form or templates of existing
printouts)
There is also a possibility to create your own templates of documents which use data of employee and/or shifts. To
create that template you have to generate a new file with any name and WZR extension (e.g. test.wzr) and open it in a
text editor (e.g. Notepad). The template have to contain header and a content of the document. The new template file
must be placed in "templates" folder.

Example of header:

<HEADER>
<TITLE>Example of header</TITLE>
<FONT_SIZE>12</FONT_SIZE>
<FONT_NAME>Tahoma</FONT_NAME>
<TYPE>htm</TYPE>
<FILE_NAME>@_grupa_nazwa,rozklad_ind,@_rok,@_miesiac_nr</FILE_NAME>
</HEADER>

Where:
TITLE: The title of the template appears on the templates dropdown list.
FONT_SIZE: Font size of the template (parameter required only for output .rtf  documents)
FONT_NAME: Font name (parameter required only for output .rtf  documents)
TYPE: Output document type (htm  - allows to format any kind of text and input tables however it is a little difficult to
edit or rtf  - has less format options but is easy to further edit).
FILE_NAME : Generated file name. File name may contain some variables (e.g. put in variable file name @month  will
cause adding to file name a month name for which the schedule is create. It will allow to automatic save the created
printouts of each month).

To place data of an employee into created document, you should use the variables. You can insert them in a template in
any position.

Examples of printouts:

Worktime schedule 11. 



Individual schedule2. 

Worktime schedule 23. 



Timetable4. 

Individual worktime card5. 



Attendance sheet6. 

Overtime list7. 



Overtime

Overtime (OT) can be added for every duty by right-click  on the square which symbolizes the assigned duty in the
calendar. Afterwards choose the option Modify  in the menu. Next in the opened Add/Edit duty  window choose Duty
overtime  and enter the amount of overworked extra hours.

Attention:  the program does not check the the correctness of the entered time with regard to rules in force!

The user can set the way of division of entered time of hours
which are counted as 50% or 100% on the Overtime  tab in
the Settings  window. A part (or totality) of overtime will be
counted as 100% if it fulfil the following conditions:

cross the time which was entered by user (e.g. when
OT is 3:15h and the user will enter 2:00h then OT
100% is 3:15-2:00 = 1h 15 min). By entering time
"00:00" OT will classified as100%.
occur between hours specified by the user. By
introducing the same hours "from" and "to" OT they
will be classified as 50%.
take place on Sunday or during holidays.
duty lasts 0 (zero) hours.

If OT fulfil conditions like 100%, the longest time will be classified. Other part is considered as 50% (it unfulfilled
contitions like 100%) GN.

Font of inscription on the square which symbolizes the duty, for which is defined OT is in a bold type.



Settings

In the Settings  window on User  tab you can set
the following data:

Company  - name of an employing
establishment,
Place ,
Zip code ,
Address ,

and
a password which protect an access to the
program against an unauthorised person,
In order to activate logging to the program
with a password, you have to enter the
password in the edit area User password . If you leave empty area behind, the program will launch without
necessity of required password.
Warning:  There is no way to recover forgotten password.

The data given on this tab (except password) can be used in print templates using variables.

On Duties  tab you can define:

Symbols of "typical" duties (i.e.: "8" and others).
These symbols are used in the Calendar  (with the
selected option Captions > Duty type  and can be
used in print templates.
The way of calculating hours during days and nights.
In order to do this, you have to enter the start time
and the duration of night hours (by default: a beginning
at 10:00 pm and the duration is 8:00 hours).
The start time of a day is settled accounts with the
different employing establishment. The default value is
00:00.

For example: with default settings, if an employee, who has 12-hour night duty, which starts at 7pm on usual day
and ends at 7am on holiday, will have completed: 3 usual hours from (from 7pm to 10pm), 8 night hours (from 10
pm to 6 am) and 1 hour of holiday (from 6am to 7am). By making a start time of a day into 7:00, hours of duty
from 6 to 7 will be categorized as usual and assigned to the day, on which the duty has started.

On Others  tab you can define:

language, in which subtitles will be displayed
in the program,
The most commonly used names of job titles
- its will appear on the selection list in the
Add/Edit employee  window,
The most commonly used names of
educations - its will appear on the selection
list in the Add/Edit employee  window,
additional data, which can be displayed in the
main window of the calendar, i.e. : number of
shift, day number, amount of duties during a
shift.



Network settings

On the Network  tab (menu: Tools > Settings >
Network) is possible to set application to work in
multiuser local network. The main is to choose
network directory, in which is installed server
instance of application. To do this click on Server
directory  button or type the path manually in the
text field. When application starts run as client,
server must be available in network. If server is
unavailable (marked by warning message and
server path in red color) then application on
computer-client used local directories regardless
network settings.

Current version of Work Scheduler Pro allows to
use server resources for:

getting printouts templates list,
It's makes easier unification of printouts used in company.
saving generated printouts, In combination with the option automatic printouts files naming contained eg. name of
user on computer-client, it allows to store printouts from all computer-clients in one plece. By checking option
only for accpted schedules  is possible to limit files quantity to these which was base on schedule with
"approved" status.
getting configuration settings.
It allows to get the same application settings on all computer stations. When this option is checked settings are
available only from computer working as server.

After checking Hide "Network" tab...  checkbox, the Network  tab will be visible only on computer-server (except when
computer-server wasn't reachable).

After click on Save button in the "dane" directory (placed in application folder) created is file net.ini. This file contains
only network settings. Is possible to copy it to folders "dane" on computers-client, without necessity setting on every
station by application.



Backup and data restore

With a view to increase the safety level of data,
which is kept in a file of Work Schedule Pro use the
option Create backup while file opening .
Selected this option backup is create during
opening the project file. Then the copy is saved in
the same directory as the opened file. The name of
the back-up file is created from the name of
opened file and an additional extension ".bak".

In case of losing data of any month or data of workers you can try to recover them. It is therefore advisable to select
option Menu > Tools > Restore backup files...  and depending on the kind of data to recover:

employees data  - in order to restore data of employees and groups of employees,
monthly data  - in order to restore information of duties and holidays during selected month

Additionally, you can activate function of automatic save of currently openened file. It is therefore advisable to enter the
time (expressed in minutes) into the program which will save the data to the file. If the current project has not been
saved yet and the file name is not given, then the program saves it to the file "document.~gr", which is located in the
directory with the program. Time equal zero minutes will turn off auto-save function.

Employees data is saved automatically while closing the program, appropriately in files such as: grupy.ini (groups of
employees data) and kadra.ini (employees data). They are located in the "dane" directory, which is in the directory
chosen by the user during the the installation of the program. On the other hand, data of assignment of duties and
holidays are saved by the user (menu: Project > Save) in the designated file.

Attention:
Backup files (with the extension ".bak") contain data from at least 2 days before.
If the restored data is incorrect, you can recreate the state before restoring it by selecting again the same option in the
menu as during restoring.

Safety of personal data of employees

Personal data of employees are stored in file named "kadra", which has binary, hard to read for unauthorized persons
format.

To increase the protection of employee personal data contained in printout files (stored in directory named "wydruki"), is
possible to automatic deleting while appliction is closing. To do it check Delete printouts files after application close
checkbox. Files created before the option was checked will not delete (you can do it manually). If, for example, after
generating a file with a printout a paper printout is created and there is no need to save it in electronic form, for the
security of personal data it is worth to mark the option causing their automatic removal (the most frequently deleted file
can be generated again in the future).

The person, who is authorized to run application, can see employee personal data displayed in application. For this
reason, it is worth restricting access to the program by applying a password.



Variables description

There are variables able to use in the own templates or to modifying existing one:

@_place - place
@_address - address
@_zip_code - zip code
@_company - company name
@_user_name - user name
@_system_user_name - Windows user name

@_symbol_of_duty_8 - symbol for the „8” duty (from configuration data)
@_symbol_of_duty_other - symbol for the duty with nonstandard duration (from configuration data)
@_symbol_of_duty_residue - symbol for the duty with duration like a group residue (from configuration data)

@_month - chosen month name
@_month_no - numeric representation of chosen month
@_month_days_qty - work days quantity in chosen month
@_month_all_shift_duty_qty - quantity of duties lasts whole shift in chosen month
@_month_days - number of days in the given month
@_year - chosen year
@_date - current date
@_group_name - chosen group of employees
@_group_normative - monthly normative for chosen group of employees
@_group_least - normative residue for chosen group of employees

@_day_no - numeric representation of day
@_day_class_title - html class name, for table header row formatting
@_day_class - html class name, for table formatting
@_n1_day_class - html class name, for table formatting for the first day of the next month
@_day_name - day name
@_day_name_short - day short name
@_day_note - day notes

@_shift_symbol[_shift_no] - whole shift duty symbol
@_shift_name[_shift_no] - shift name
@_shift_from[_shift_no] - hour of begining of the shift
@_shift_from_pd[_shift_no] - hour of begining of the shift as percent of day duration
@_shift_to[_shift_no] - hour of ending of the shift
@_shift_to_pd[_shift_no] - hour of ending of the shift as percent of day duration
@_shift_duration[_shift_no] - duration of shift
@_shift_duration_pd[_shift_no] - duration of shift as percent of day duration
@_shift_no[_shift_no] - shift order number
@_duty_who[_shift_no] - short names of workers who have duty on chosen shift
When you use any of six above mentioned variables between tags <_SHIFT> and then isn’t necessary to use square
braces and shift number

@_shift_quantity[number] - shifts quantity for given group, instead [number] is possible to set number that increase
result of variable.
@_day_who_8 - workers, who on given day have duty lasts as base duty
@_day_who_least - workers, who on given day have duty lasts as normative residue
@_day_who_other - workers, who on given day have duty with other duration
@_day_who_holiday - workers, who on given day are on holiday
@_day_who_dayoff - workers, who on given day have dayoff
@_day_who_dayoff_1 - workers, who on given day have dayoff for work on Sunday
@_day_who_dayoff_5 - workers, who on given day have dayoff owing from 5-days work week
@_day_who_dayoff_7 - workers, who on given day have dayoff for work on Saturday
@_day_who_dayoff_h - workers, who on given day have dayoff for work on holiday
@_day_who_sick_leaves - workers, who on given day stay on sick leave
@_day_who_other_dayoff - workers, who on given day are absent from other reasons
@_day_duties_count - quantity of duties on given day
@_day_max_duties_week - the biggest number of duties on day in given week (week: from Monday to Sunday)

@_all_sum - the sum of all worked hours (by all employees)



@_all_do_sum - the sum of all worked, as dayoffs, hours (by all employees)
@_duty_type - shift number on which duty is begining
@_duty_shift - shift name on which duty is begining
@_duty_note - note added to duty
@_duty_symbol - duty symbol
@_duty_dayoff_symbol - duty or dayoff symbol, depends on which is inserted
@_duty_duration - duration of duty
@_duty_duration_pd - duration of duty as percent of day duration
@_duty_d_quantity - normal hours included in the duty
@_duty_n_quantity - night hours included in the duty
@_duty_h_quantity - holiday hours included in the duty
@_duty_day_duration - duty duration (assigned to day on which it begins)
@_duty_day_d_quantity - normal hours included in the duty (assigned to day on which it begins)
@_duty_day_h_quantity - holiday hours included in the duty (assigned to day on which it begins)
@_duty_day_duration_all - duty duration with overtime (assigned to day on which it begins)
@_duty_from - starting hour of duty
@_duty_from_pd - starting hour of duty as percent of day duration
@_duty_to - ending hour of duty
@_duty_to_pd - ending hour of duty as percent of day duration
@_duty_fromto - starting and ending hours of duty
@_duty_fromto_all - starting and ending hours of duty with overtime
@_duty8_to - ending hour of base „8” duty
@_least_to - ending hour of normative residue
@_duty_overtime - overtime quantity
@_duty_overtime_to - ending hour of overtime
@_duty_100_overtime - overtime quantity calculated as 100%
@_duty_50_overtime - overtime quantity calculated as 50%
@_duty_dayoff_quantity - quantity of hours of duty or dayoff if inserted
@_duty_day_dayoff_quantity - quantity of hours of duty or dayoff if inserted
@_dayoff_quantity[_...] - quantity of hours of dayoff if inserted
@_dayoff_type - kind of dayoff (taken from Settings > Dayoffs)
@_dayoff_name - name of dayoff (taken from Settings > Dayoffs)

@_n1_day_symbol - duty symbol on first day of next month
@_n1_day_d_qty - quantity of normal hours included in duty on first day of next month
@_n1_day_n_qty - quantity of night hours included in duty on first day of next month

@_worker_no - order number of worker
@_worker_surname - worker surname
@_worker_name - worker name
@_worker_nick - worker nick
@_worker_adress - address
@_worker_postoffice - postoffice
@_worker_zipcode - zip code
@_worker_phone - phone number
@_worker_email - e-mail
@_worker_occupation - occupation

@_worker_part_time - part time
@_worker_prev_month_extra_time - overworked or unworked hours from previous month
@_worker_manual_correction - manually corrected normative

@_worker_holiday_remain - remain holiday hours
@_worker_holiday_remain_last_year - remain holiday hours from previous year
@_worker_holiday_remain_this_year - remain holiday hours from current year
Attention: Variables relative to holiday hours returns values from day of printout create, regardless of chosen month.

@_worker_identity_number - worker identity number
@_worker_education - worker education
@_worker_courses - worker courses
@_worker_user1 - additional data 1
@_worker_user2 - additional data 2
@_worker_user3 - additional data 3
@_worker_color_rgb - color assigned to worker in RGB format



@_worker_normative - worker worktime in chosen month
@_worker_normative_wd - worker worktime in chosen month without dayoffs
@_worker_all_sum - worked hours with overtime in chosen month
@_worker_all_sum_wo - worked hours without overtime in chosen month
@_worker_duty_sum - hours worked as duties with overtime in chosen month
@_worker_duty_sum_wo - hours worked as duties without overtime in chosen month
@_worker_d_sum[day symbol(s)] - normal hours worked in chosen month. May be limited to choosen days eg.
Saturdays and Sundays @_worker_d_sum17 (1 means Sunday, 2 Monday, etc.. until to Saturday marked as 7)
@_worker_n_sum - night hours worked in chosen month
@_worker_n_sum_qty - quantity of night duties in chosen month
@_worker_h_sum - holiday hours worked in chosen month
@_worker_ab_sum - dayoffs hours in chosen month
@_worker_ot1_sum - overtime hours calculated as 100%, worked in chosen month
@_worker_ot2_sum - overtime hours calculated as 50%, worked in chosen month
@_worker_ot_sum - all overtime hours worked in chosen month
@_worker_difference_normative - the difference between worked hours and month normative
@_worker_difference_worker_normative - the difference between worked hours and worker month normative
@_worker_difference_worker_normative_wo - the difference between worked hours and worker month normative
without overtime
@_worker_difference_worker_normative_wd - the difference between worked hours and worker month normative
without dayoffs

Dayoff symbols:
a - on demand
u - holiday
m - maternity
w - parental leave
s - sabbatical
z - sick leave
o - childcare
i - other
n - play truant
b - LWOP (leave without pay)
d - exemption of the child
r - family member care
1 - dayoff for work on Sunday/holiday
7 - dayoff for work on Saturday
5 - as result of 5-working days week
9 - dayoff for work on Holiday
h - rehabilitation
k - special leave
j - parental
t - paternity
ż - day without duty on request of the employee

@_dayoff_type_qty_[dayoff_symbol(s)] - dayoff type (taken from Dayoffs tab in the Settings window) with monthly
hours
@_dayoff_sum_[dayoff_symbol(s)] - dayoffs hours in chosen month
@_worker_duty_dayoff_qty - duties and dayoffs quantity in chosen month
@_worker_duty_qty - duties quantity in chosen month
@_worker_dayoff_qty - dayoffs quantity in chosen month
@_dayoff_to - number of day in which dayoff is ending
@_dayoff_days_quantity - dayoff duration as days
@_dayoff_work_days_quantity - dayoff duration as work days
@_dayoff_hours_quantity - dayoff duration in hours as duration of duties within it
@_dayoff_hours_norma_quantity - dayoff duration in hours depends from normative

@_period_no - following number of month in period
@_period_month_no - number of month in the year (from 1 to 12)
@_period_month - name of the month
@_period_month_days_qty - days count in the month
@_period_year - year
@_period_months_qty - quantity of months contained in period



@_period_from - first day of the period (date)
@_period_to - last day of the period (date)
@_period_normative - group normative for given month
@_period_sum_normative - group normative for given period
@_period_worker_normative - worker worktime in month
@_period_worker_normative_wd - worker worktime in month without dayoffs
@_period_worker_duties - hours worked as duties in month
@_period_worker_dayoffs - hours worked as dayoffs in month
@_period_worker_worked - hours worked as duties and as dayoffs in month
@_period_sum_worker_normative - normative for whole period
@_period_sum_worker_normative_wd - normative for whole period without dayoffs
@_period_sum_worker_duties - hours worked as duties in period
@_period_sum_worker_dayoffs - hours worked as dayoffs in period
@_period_sum_worked - hours worked as duties and as dayoffs in period
@_period_sum_worker_normative_difference - the difference between worked hours and worker normative in whole
period

@_dayoff_desc_symbol - dayoff symbol set by user in Configuration window. Variable must be placed between
DAYOFF_DESC tags.
@_dayoff_desc_name - dayoff name set by user in Configuration window. Variable must be placed between
DAYOFF_DESC tags.
@_status - schedule status (unapproved/approved)

@_symbol_of_duty_8 - duty „8” symbol (from Configuration)
@_symbol_of_duty_residue - symbol of duty with duration equal to group residue (from Configuration)
@_symbol_of_duty_other - symbol of duty with other duration (from Configuration)

@_read_all_groups - On any printouts may be showed duties worked by employee in others groups (in the same month
in different groups). Variable should be placed at template begin.
@_dot_as_time_sep - Sets dot as hour and minute separator instead colon. Variable should be placed at template
begin.
@_clear_auto_eols - Removes all end of line chars. Variable should be placed at template begin.
@_eol - end of line

Additionally:
if variable value is zero and zero must be appeared on printout then at the end of variable add 0 (zero), eg.
@_worker_d_sum0
if variable value is hour and needed display format is 00:00 then at the end of variable add : (colon), eg.
@_worker_d_sum:
if variable value is zero and zero no need to be appeared on printout then at the end of variable add _ , eg.
@_worker_d_sum_

Above mentioned variables may be placed beetwen tags:
<_DAY> variables* </DAY> variables* relative to days of chosen month, eg. text line from template <_DAY>@_day_no,
</DAY> changes to text: 1,2,3,… etc. to end day of the month
<_WORKER> variables* </WORKER> variables* relative to following workers, eg. text line from template
<_WORKER> @_worker_surname @_worker_name, @_worker_all_sum </WORKER> gives list of workers with its
monthly worked hours on the printout
<_SHIFT> variables* </SHIFT> variables* relative to shifts
<_GROUP> variables* </GROUP> variables* relative to groups of workers
<_OVERT> variables* </OVERT> variables* relative to overtimes worked in chosen group
<_MONTH> variables* </MONTH> variables* relative to period (begins form @_period_)
<_DAYOFF> variables* </DAYOFF> variables* relative to dayoff (begins form @_dayoff_). In the calendar must be
active day, in wchich current worker has dayoff.
<_DAYOFF_DESC> variables* </DAYOFF_DESC> variables* relative to names and symbols of dayoffs. Only dayoffs
used in schedule are included.

The tags may be nested (max. 2 levels of nesting) eg.
<_WORKER>@_worker_surname @_worker_name
<_DAY>
@_duty_dayoff_symbol
</DAY>
</WORKER>


